
Basic Layer Usage
1. Very simple image editing tools (like the Paint program that comes in the 

Accessories with Microsoft Windows) do not have layers.  When you draw on your 
image, it replaces what was there before.  If you erase, you don't get what was 
underneath:  you just get a solid background color.  It's hard to get any serious 
image editing done with those limitations.  Among other things, you can't 
reposition a foreground object in front of a different part of the background, 
without repainting the background behind where it was.  So all serious image 
editing software has layers.  Once you become accustomed to working with 
layers, you will never want to go back to using software that doesn't have them.

2. Most image file formats (e.g., PNG, JPG, GIF, BMP) do not support layers, so 
images that you save in those formats will be "flattened", which makes further 
editing more difficult.  If you still may want to edit an image, it's always best to 
save in a format that will preserve the layers.  In Gimp, the best format to save in 
is .xcf (Gimp format).  Besides layers, this format also saves your paths and other 
useful things, but layers are the main thing.  Other image editors have their own 
formats for the same reason.  When you are satisfied with your image, you can 
Save As to make a .png or whatever.

3. Open 01-basic-layer-usage.xcf.  This simple example has just four layers:  a plain 
orange background, a blue circle, a green square, and some red letters.

4. In the Layers dialog, you see a list of the layers.  Notice there's a thumbnail 
(miniature previews) of each, so you can tell them apart.  You can also give them 
names: right-click and Edit Layer Attributes.

5. You can change the stacking order of the layers.  Notice along the bottom of the 
layers list several buttons.  The blank page creates a new layer.  The up and down 
arrows move the currently selected layer up or down in the stack.  Select the blue 
circle layer and move it above the green square. Notice that the corner of the 
square is hidden behind the circle.

6. Select the green square layer and move it above the circle again. Notice that 
although you can now see the corner of the square, the circle still shows through. 
This is because the square is partly transparent.  The "opacity" slider, at the top of 
the layer list, controls the transparency of the selected layer.  Slide it down to zero 
and watch the square disappear.  Slide it back up to 100 and watch the corner of 
the square cover up the circle.

7. Use the move tool to place the red word "Layers" in a different spot.
8. Clicking the "eye" next to a layer toggles its visibility.  Turn off the green square.
9. There are three more buttons at the bottom of the layers list.  The one with a page 

in front of another page duplicates the current layer, so that you have two of it. 
You can make the old one invisible and keep it as a backup, or you can use the two 
together, e.g., apply some effect to the top one and then reduce its opacity to fade 
out the effect.

10.The other two are less useful.  The anchor button takes a "floating" object (from 
copy/paste) and makes it part of the current layer, but I usually make it a new 
layer (with the new layer button) instead.  The trashcan deletes the current layer. 



Lightening and Brightening
1. Open P6040005.JPG.  This photo was taken under fairly poor lighting conditions, 

so it's dark.  Save as 02-lightening.xcf

2. The first thing we're going to do is look at the levels.  Layer->Colors->Levels.
1. Look at the input levels.  Notice how all the image color is concentrated toward 

the dark end of the spectrum, with a thin tail on the light end.
2. Drag the right/light end of the range toward the left until it's closer to the point 

where there's more color imformation in the image.
3. So now the light parts are light, but the medium parts are still pretty dark. 

Notice how most of the color information is still to the left/dark of midpoint.
4. Drag the middle-pointer for the range a bit to the left.
5. When you are mostly satisfied with how light the image looks, click Ok.

3. The image is lighter, but now it's kind of dull (gray) and also grainy.

4. One of the best fixes for graininess is to scale the image down.  
1. Currently this image is 3072x2304 pixels, which is larger than we probably 

need, especially for the web.  So let's scale it down a bit.  By half, perhaps.
2. Image->Scale Image.  Change the width to 1536.  Make sure we're using the 

best possible interpolation, and hit Scale.
3. It's still a little grainy, and the brightening we're about to do will probably 

make it even more grainy, so we'll be coming back to this issue.

5. We can improve the dullness with a bit of brightening.  The best brightening trick 
I know is to use an unsharp mask with a large radius.  With a small radius, an 
unsharp mask makes an image details stand out better, which makes the image 
appear sharper.  With a large radius, it makes larger areas stand out better, 
which makes the image seem brighter.  
1. Duplicate the layer first, so that if the effect is too much we can just back off 

the opacity a bit and get a smaller amount of it.
2. Filters->Enhance->Unsharp Mask.  Set the radius to about 50 and hit Ok.  
3. It takes a moment...  but when it finishes the image should look brighter.  Try 

toggling the visibility (eye icon) for the brightened layer to see the difference.
4. If the brightness is a bit much, reduce the opacity of the brightened layer, to let 

the (unbrightened) layer underneath partly show through, until it looks better.
5. When you are satisfied with the brightness, right-click the layer and hit Merge 

Down to apply the effect to the layer below.

6. If the image still looks a little grainy, we could try a blur filter, or scale down a bit, 
or both.  There are also more advanced tricks (e.g., selective blur), but for now 
let's use the simple tricks.  
1. Filters->Blur->Blur.  It's less grainy now, but... blurry.
2. At 1536x1152, the image is still larger than we need.  Image->Scale Image
3. Set the width to 768 (half of 1536).  Make sure we're using the best possible 

interpolation, and hit the Scale button.

7. It still isn't the best picture ever, but compare it to the original.



Fixing Uneven Lighting
1. Open P4180021.JPG.  This is a photo we took at the Pirate's Curse event.
2. Notice how much lighter the top part of the image is than the bottom part. 

The whole thing could stand to be lightened a bit, but the bottom part 
needs more of the effect than the top.  We'll use a layer mask to do this.

3. Save as 03-uneven-lighting.xcf
4. Start by duplicating the layer.  The original, unlightened version of the 

image will stay on the bottom layer, and we'll use the layer mask to let it 
show through in some areas more than in others.

5. Select the top layer.  We'll lighten this layer to the maximum extent 
necessary (i.e., until the darkest part looks right), and we'll use the layer 
mask to apply different amounts of the effect in different areas.

6. Layer->Colors->Levels.  The color on this one is somewhat better than on 
the previous, spread out over more of the spectrum, so leave the right and 
left sliders alone.  Move the middle one, toward the left, until the darker 
areas look better.

7. Hit Ok.  Notice that most of the image is now too light.  So let's fix that...
8. Right-click the lightened layer (in the layers list) and choose Add Layer 

Mask. Initialize the mask to white (full opacity) for now.  Ok.
9. We could draw on the layer mask now, but for this image what we need is 

pretty simple:  we need white (full opacity) toward the bottom of the 
image, and we need a darker mask (more transparency) higher up.  We can 
do this with a simple gradient.  

10.Select the gradient tool, and apply a gradient from near the top of the 
image, straight down to near the bottom.  Assuming our current colors are 
black foreground and white background, this should create a layer mask 
that is a smooth transition from transparency near the top to full opacity 
near the bottom of the image.  

11. If it isn't quite what you need, you can re-apply the gradient a little 
differently, as many times as you like.

12.When you get the lighting nice and even, so the whole image looks equally 
light (or equally dark), you can right-click the lightened layer (the with the 
mask) in the layers list and choose Merge Down.  This takes the effect on 
the masked layer, using different amounts of  it in different areas 
according to the mask, and applies it to the layer beneath.

13.You can then do any further processing that is needed (e.g., lighten or 
brighten the whole thing some more, or whatever).



Selective Erasing

1. Whenever you erase part of a layer, it becomes transparent.  Whatever 
is on the layer beneath shows through. With a suitable background, 
and judicious use of the eraser, you can essentially make things 
disappear.

2. Open the example file, 04-selective-erase.xcf

3. Here we're trying to do a Max Headroom knock-off, but our 
photograph of a person's head has an unnecessary bookshelf in the 
background, which obscures the wavy lines and static.  So we want to 
erase the bookshelf and books and stuff, leaving just the face, in front 
of the wavy-lines background.

4. Select the layer with the face.

5. Take the eraser tool, and select a medium-sized brush, with a little bit 
of a soft edge.

6. Erase around the edge of the face, clearing the unwanted background 
away so that the wavy lines and static show through.

7. If you erase part of the face by mistake, the eraser's tool options 
include an "Anti-Erase" setting that will allow you to unerase.

8. You may find it helpful to use a larger brush to quickly clear away large 
areas, or a smaller brush for details.



Scaling to Fit
1. You may have seen the poster for this program, with Ellen sitting in the boxcar. 

When we were doing that image, one of the things we had to do is scale down part 
of it.  Open the example 05-scaling.xcf

2. Notice that Ellen is too large to sit in the boxcar.  We'll have to scale her down.
3. In the layers list, right-click on the Ellen layer and choose Scale Layer.
4. To fit properly in the boxcar, in this case, we want her to be about one quarter (or 

perhaps up to one third) of her current size.  Currently she's 932 x 1420.
5. One-quarter of 932 is 233, so set the width to 233 pixels.
6. Because the width and height are linked, the software automatically changes the 

width to 355, to preserve the aspect ratio.  (If you need to stretch or compress a 
layer in one direction more than in the other direction, you can unlink the two 
numbers by clicking on the chain-link icon to break the link.  Then you can 
change one of the numbers without having the other change.  But in this case,  
we want to keep the same shape, and only change the size, so we left the width 
and height linked.)

7. Click the scale button.
8. Now Ellen is small enough sit in the boxcar.  Grab the move tool and position the 

Ellen layer in the right place.
9. There's more that we can do with this example – see the boxcar entry in the 

intermediate examples folder.



Color Mapping
1. Serious photo editing software comes with a large collection of filters, which let 

you do things that would otherwise be difficult or tedious.  One of these filters is 
the color range mapping, which lets you replace one whole range of colors with a 
different whole range of colors.  Another is the Colormap Rotation.

2. There are simpler ways to replace one individual color with another color (for 
example, you can Select->By Color and then Edit->Fill), and that might work for 
simple drawings, but real photographs have shading.  A simple object may have 
dozens of individual colors in it to create the overall effect of "red", for example. 
To change the color of such an object, you need a color mapping filter.

3. Open the example, 06-color-mapping.xcf
4. I took a photograph of a red fire hydrant, but perhaps I need it to be a different 

color.  Maybe I'm going to put it in front of a red fire truck, and it won't show up 
well.  Or maybe there's another reason.  In any case, we want to change the 
hydrant's basic color.

5. We don't want to change the color of the grass, so select the layer with just the 
hydrant.

6. Filters->Colors->Map->Colormap Rotation.
7. The From range controls which colors that are currently in the image we want to 

change.  The hydrant is red, so we want to change all the red colors.  By default the 
range is centered on orange/yellow, so 
drag both the starting and ending parts 
of the range about forty-five degrees to 
the right, so that the From range runs 
from magenta up through orange.  This 
effectively selects the red colors in the 
hydrant.

8. The To range controls what colors we 
want the changed stuff to end up being. 
By default, it's centered around 
yellow/orange.  Notice that the preview 
of the hydrant is yellow/orange.

9. We want the hydrant to be more of a 
blue color, so drag the start and end of 
the To range around until it is centered 
on blue.

10.You can see the result in the preview.  When you are satisfied, click OK.



Fixing Redeye
1. Everybody knows about camera redeye.  Open the example, 07-redeye.xcf
2. I look strange enough without red eyes.  Let's fix them.
3. First, we want to select just the areas that are red, that shouldn't be.  Zoom in on 

the eyes, and use a selection tool (such as the lasso) to select the red portion. 
(You can do the eyes separately, but you can also hold down the shift key while 
selecting to add an additional section to what you already selected.  Thus, you 
can do both of the eyes at once if you like.)

4. There are a couple of ways to fix redeye.  We could try a colormap rotation, like in 
the previous example, but at the moment let's just get rid of the red.  With the red 
in the eyes selected, do Layer->Colors->Desaturate.

5. Zoom back out to see the difference this makes.  The eyes are now gray, which is 
not too far off from my natural eye color.

6. Fixing the rest of the image is left as an exercise.



Using Paths (Beziers)
1. Paths (controlled by bezier curves) are a way of selecting complex shapes.  Open 

the example, 08-paths.xcf.  We want to select just the hydrant, so we can separate 
it from the grass in the background.

2. Select the paths tool.
3. One of the cool things about paths is that once you have drawn a path, you can go 

back and change it by dragging the points around.  So you don't have to get every 
point positioned exactly in the right place on the first try.

4. So zoom in on one edge of the hydrant and just start clicking points along the 
edge.  Wherever the edge changes direction, you want a control point.  (A few 
extra ones in between doesn't really hurt anything, either.)

5. Keep doing this all the way around the edge of the whole object you want (in this 
case, the fire hydrant) until you get back to the first point.

6. Now that you've got your points placed, you can move them around.  Just drag a 
point to move it.

7. If you hold the Ctrl key while dragging a point, you will "pull out" a curve control 
point, which allows you to create smooth curves, which can be convenient for 
some things.  However, in most cases when you're selecting a complex shape you 
can just as easily use a whole new point at each place where the edge changes 
directions.

8. Once you have the path where you want it, you can select the area defined by the 
path via Select->From path.  Now you can copy the selection, paste it onto a 
separate layer, use filters and other editing tools to edit only the selection, or 
whatever else you need to do.



Sitting in the Boxcar

9. We took the boxcar out and photographed it.  Open P3250013-boxcar6.JPG, Save as boxcar.xcf
10. Then we took a photo of Ellen.  Open P5200023.JPG.

1. Use the rectangle selection tool to select a rectangle containing Ellen.
2. Copy that, switch back to boxcar.xcf, paste, and make it a new layer.
3. Close P5200023.JPG

11. We don't want her background, so we're going to carefully select just Ellen (and the book).
1. We'll use the paths tool (bezier).
2. Zoom in so we can see what we're doing.
3. First just click from point to point, drawing an approximate path around Ellen (&book).

1. Don't worry too much about the details right now; we'll fine-tune it in a moment.
2. Also don't worry about inner areas, like between the glasses frame and her face.
3. You can pan around with middle-drag.

4. Once you've got a first-draft outline, duplicate the path, then fine-tune it.
5. When you're satisfied, Select->From Path, copy, paste, new layer.  Turn off the old.

12. If we want her to sit in the train car, she's much too large.  In the layers list, right-click the layer 
with the clipped-out Ellen, Scale Layer, and use a dimension about 1/3 of the original size.

13. Position her.  For an ideal fit, we'd like to have just a bit of her "hidden behind" the front part of 
the train car doorway.  Since the train car is all one layer, we can't actually do that, but we can 
fake it with selective erasing.  So go ahead and position her with some overlap to the doorway.

14. Decrease the layer opacity so that we can see where the edge of the doorway is behind her.
15. Take the eraser tool, with a smallish brush tip with a bit of softness to its edge, and erase the 

portion of her that is in front of the wall it should be behind (zooming as needed).  If you erase 
too much, the eraser tool has an "Anti erase" option that can be used to touch up the edge.

16. Zoom out.  She's too dark for the scene.  Worse, her shoes are too dark for the rest of her.  The 
first problem we could correct by just lightening the whole layer, but to solve the second issue 
we want to lighten some parts of the layer more than others.  So, duplicate the layer first, and 
we'll use a layer mask to apply more of the lightening to the bottom part of the layer.

17. Select the new copy of the layer, and do Layers->Colors->Levels.  Drag the middle slider (on 
the input levels) to the left until her shoes are as light as we want them.  The rest will be too 
light, but we'll fix that in a moment.

18. Right-click the layer (in the layers list) and choose Add Layer Mask.  A layer mask lets you 
"mask out" parts of a layer, allowing what's behind (in this case, the non-lightened Ellen) to 
partly show through, selectively reducing whatever effect we applied to the masked layer, for 
some parts of the layer.  Initialize the layer mask to white (full opacity).

19. Now we can draw on the layer mask, but we don't really want to do a lot of detail here.  We just 
want the top part to be weaker (gray) and the bottom part stronger (white), so that the 
lightening we did is most prominent on the shoes.  We can do this with a gradient.

20. Select the gradient tool.  We do want some lightening on the top of the layer, so change the 
black to a medium gray.

21. Apply a gradient to the layer, starting from about the middle and ending somewhere down near 
her feet.  (Beyond the ends of the gradient will be filled with the starting and ending color, 
which is fine for what we want.)  You can retry this several times, adjusting the color of gray for 
the top and the starting and ending positions of the gradient until it looks right.

22. Right-click the masked layer (in the list) and merge down, to combine the lightened layer with 
the other one.

23. Now Ellen looks light enough, but a bit dull, so let's do some brightening.  Duplicate the layer 
first, so that we can decrease the opacity if the effect comes out too strong.

24. The best lightening trick I know is an unsharp mask with a larger radius than you would 
usually use for regular sharpening.  Filters->Enhance->Unsharp Mask.  Set radius to 35.

25. If the brightened layer is too much, back off its opacity until it looks right, then merge down.
26. If the edges are too strong in places, you can soften them with the eraser tool.



Miniature Server on the YA Bookshelf

1. Found the photo of the server (using Google Images search).
2. Opened in Gimp, Save As, downloaded/DELL_PowerEdge_2800.xcf
3. Remove the white background (easy because it's plain white):

1. Duplicate Layer and turn off the original layer's visibility.
2. [Layers Dialog] Add Alpha Channel
3. Magic wand tool, click white bg on left, shift-click white bg on right.
4. Select->Grow 1px
5. Cut

4. Crop, and note the dimensions (about 270x337).
5. Note the angle/perspective of the server.
6. So we took a digital photo of a bookshelf with an empty space, from the same 

angle...
7. Open the photo, P3250009.JPG
8. Using rectangle selection tool, check size of the empty space.  Compare to the 

450x337 server, and note that there's more than enough room on the shelf for the 
server to fit.  In fact, we could easily manage 675 x 600, so the space is twice as 
large as it absolutely needs to be for the server.  We want a little spare room, so 
let's scale to two-thirds.

9. So scale the shelf down to 2048 x 1536.  Zoom in.
10.Save As, shelfspace.xcf
11. Now, let's get the server in the picture.

1. Select the server and hit Copy.
2. Go to the shelf space image and hit Paste.
3. Make that a new layer and position it appropriately.

12. Zoom in on the server and notice the weird top edge.  Let's fix that...
1. Select the eraser tool
2. Brush selection -- pick out something small and soft.
3. Erase that black/white double line off the top.
4. Oh, look, there's one on the bottom too, erase that.

13. Zoom out (to about 50%) and have a look at it.
1. The lighting isn't exactly right, but it's close enough for government work.

14. It almost looks like there's room for *two* servers...
1. Duplicate the layer.
2. Position it.  The one on the left has to sit up a bit because it's on the bookend 

foot, but it works.  Make sure it's not in front of the main part of the bookend.
15. Then again, what if the back of it extended behind the main part of the bookend?

1. Scoot it over and zoom in on the boundary.
2. Now we need some selective erasing.  
3. Make the layer 50% transparent so we can see what we are doing.
4. Select the eraser tool and a suitable brush (I chose the 7x7 soft brush.)
5. Carefully erase away the undesired portion.
6. Demonstrate how inadvertently erased bits can be unerased if needed.



People in the Candy Dish

1. Open the photo of the candy dish, P3250013.JPG
This photo just cries out for a "Honey, I Shrunk the Kids" knock-off.

2. Save As candy-dish.xcf
3. So we need a couple of pictures of people, but they don't need to be very large.

A) We got Ellen and Amy in the background at the chess tournament.  Open P3290025.JPG
1. Rect-select the two women in the background.  Copy.
2. Go back to candy-dish and paste.  Make it a layer.
3. Note that it's bigger than it needs to be.  That's good, because it's not such great quality, 

and reducing its size after we clean it up will help.
4. Close the image we got that from.
5. Reposition the new layer and zoom in on it so we can see it well.
6. We're going to use the path tool to draw a bezier-curve path around Amy, to separate 

her from the background.
1. Select the paths tool and do a quick click-click-click outline job.  While doing this, 

explain the generalities of how beziers work.
2. Zoom in even more and move any of the control points that need to be moved, 

explaining how the control points work while doing it.  Note the use of the Ctrl key 
to "pull out" the control points.

3. Pan around the border (except the bottom), looking over the spline.  Note how it's 
hard to tell exactly where the edge is, especially between hair, purse, and shadow. 
Just do your best, and scaling down later will help to reblur the edge with the new 
background.

4. Zoom back out enough to see all of Amy.
5. Show the Paths dialog.  Name the path and note that we'd be able to come back to it 

again later if we wanted to.  We could even duplicate this path and edit the copy.
6. For now, Select->From Path, and copy.
7. Paste, and make that a new layer.  Turn off the other pasted layer and show off our 

newly isolated person against the background.  Deselect the path tool for a better 
view.

8. Zoom out and note how much darker this is than the background.
1. Layers->Colors->Levels.  Explain the basics of the levels tool.
2. Move in the ends of the input levels range to match where there's actually color 

information in the picture.  That helps a little...
3. Note how unbalanced the range is.  Move the middle marker on the input range 

to the left.  Go way too far and show what that looks like, then back off to about 
1.61.  Note that this is still too dark, but we have another trick or two up our 
sleeve yet, and we don't want to totally wash out the color.  Hit OK.

9. Time to scale it down a bit.  Right-click the layer (in the layers dialog) and hit Scale 
Layer.  Note current size.  Grab a calculator and figure half-size.  Do it.

10. Select the move tool and position it over the candy dish.  Play with the positioning 
for a moment.  Note we can erase part of her to make it look like she's behind candy.

11. Make her about 70% opaque so we can see behind.  Find a good position for her.
12. Grab the eraser tool, and a fuzzy brush (maybe 13x13).  Zoom in.  Erase the parts of 

her that are behind candy.  Go a little too far and erase part of that's wanted.  
13. Make her more opaque and demonstrate anti-erase, "painting" her back in.
14. Zoom out to show the whole dish.  She's still too dark.  Dupe the layer...

1. Open the unsharp mask tool.  Explain briefly.  Set radius to 40.  Hit OK.
2. Try the levels tool again, but note that it washes her out too much.  Cancel.

15. If there's a "halo" around her, use the erase tool to clean it up.
B) There's a shot of Ellen from the Spiderwick party, wherein she's sort of hunched over. 

Normally that's not a good shot, but for this it might work out great.  



1. Open ../2008-spiderwick/P2090016.JPG
2. Rect select Ellen, copy, paste into candy dish, make it a new layer.  Close the other.
3. It's huge.  We can scale it down some now, and more later.  For now, scale it down to a 

quarter of its initial size.  Still plenty of room to scale down again later.
4. Position it over the table and zoom in on it.
5. Grab the path tool and quickly outline her, from the interfering arm up.
6. Zoom in and pan around the edge messing with control points as needed.
7. Look at paths dialog.  Name this new path.
8. Select->From Path.  Copy, Paste.  Make it a new layer.
9. Turn off the old layer and deselect the paths tool.  Zoom out and look.
10. Scale the layer down to half size (about 112 px wide).  Note that she's a little bigger than 

Amy, so we'll put her nearer the front.
11. Make her party transparent and use the move tool to position her.  Zoom in.
12. Note that we'll need to "paint in" some more of her jeans.  We can do that.

1. Zoom way in and make her opaque.
2. Laso a section of her jeans, copy, paste, new layer, move into position.

Repeat this step until there area in question is fully covered.  This gives us 
something to work with as we construct the missing parts of the image.

3. Merge Down until all those filler bits are on a single layer.
4. Position it behind the main Ellen layer.
5. Make partly transparent and erase away the totally unneeded portion of the filler 

layer (i.e., trim the edges).
6. Note that there are too many wrinkle/edge effects, due to the nature of the 

copy/paste job.  Those are mostly composed of lighter/darker pixels.
1. So select a small section of medium-darkness blue-jean pixels and cover the 

worst of that.  Combine onto a single layer.
2. Note the very noticeable edge between the Ellen layer and the filler.

So grab the eraser tool with a very fuzzy brush and trace that edge of Ellen.
7. Note that the shirt doesn't come down far enough in the one area.

1. Using the color select tool, grab a medium green from the shirt.
2. Create a blank layer above Ellen.
3. Grab the brush tool and a smaller fuzzy brush, and brush in most of it.
4. Grab a darker tool and smaller brush and fill in the shadow.
5. Now that part of the shirt looks flat and fake because it is solid-color.

But at least it's there, that's a start.
6. With the smaller brush, grab another color from the shirt and dab it onto the 

patch area in a couple of places to make texture.  Repeat as needed.
8. The jeans still don't look right.  Too flat.  We need some shading.

1. Grab the brush tool, and make it about two-thirds transparent.  This will let us 
paint in some shading but have it not completely take over, i.e., what's under it 
will show through.

2. Grab a blue off the jeans and darken it.  Maybe increase the saturation a bit too.
3. Zoom in and paint on the layer above Ellen with the brush tool.  

1. Shade/darken the right side of each leg.
2. Grab an even darker color and the smallest fuzzy brush and draw a line 

between them.
13. Zoom out and have a look.  
14. Part of her is in front of something it should be behind. Grab the eraser tool and fix.
15. Note how sharp the edge is between her and the bg.  Grab the eraser tool and soften it.


